Si vous avez une erreur de ce type :

en voulant faire une application Python + Glade + Gtk c’est certainement que le début de votre fichier python ressemble à cela :

alors qu’il devrait ressembler à ceci :

Et il faut ajouter une majuscule à toutes les références à gtk dans ce même fichier Python : « gtk.main() » devient « Gtk.main() »

 

Il faudra installer gi :

Et hop, le tour et joué !

 

Pour ne pas rester bête !?

Glade (l’éditeur de fenêtres) veut utiliser GTK+ version 3.xx.
Python charge GTK+ version 2.xx quand vous utilisez pygtk
Alors que GObject fait référence à la version 3.xx